|
主题设置

卡片式面板通常用于非白色背景色的主体内

WIN 安装 MySQL

在 Windows 上安装 MySQL 通常可以通过下载 MySQL 安装程序并按照安装向导进行操作来完成。

下载 MySQL

登录 MySQL 官网 。

MySQL 官网

进入下载菜单

下载菜单

选择下载社区版

社区版

下载 window 的安装文件

WIN 安装文件

点击下载

点击下载

下载成功

下载成功

安装 MySQL

双击安装文件进行安装,本次选择 "Full",然后点击 "Next" 。

开始安装

点击 “EXecute”

安装内容

会自动逐一进行安装

逐一安装

全部安装完成后,点击 "Next" 。

安装

点击 "Next"

点击 Next

继续点击 "Next"

点击 Next

选择使用强密码,点击 "Next" 。

密码设置

设置好密码,然后点击 "Next" 。

输入密码

点击 "Next"

WIN Service

继续点击 "Next"

Server File

点击 "Execute",耐心等待执行完成。

Apply Configuration

正在执行

Applying Configuration

执行完成后, 点击 "Finish" 。

执行完成

点击 "Next"

Product Configuration

点击 "Finish"

Route Configuration

点击 "Next"

Product Configuration Finish

输入之前设置的 MySQL 密码,点击 "Check",验证通过之后,再点击 "Next" 。

Connect To Server

点击 "Execute",等待执行完成,再点击 "Finish" 。

Apply Configuration Apply Configuration

点击 "Next"

Apply Configuration

上面两个选项不需要打钩,最后点击 "Finish",安装到此全部结束。

安装完成

配置 MySQL

安装完成后,打开命令窗口,然后输入命令行:mysql -u root -p

出现 “'mysql' 不是内部或外部命令” 的提示,说明需要对 MySQL 进行配置。

在桌面上右键点击“我的电脑”,然后点击“属性”,进入系统信息设置界面,接着点击“高级系统设置”。

我的电脑属性

切换到 “高级”,点击 “环境变量”。

环境变量

找到 “系统变量栏” 里面的 "Path",双击打开,然后点击 “新建”。

新建 Path

输入 MySQL 对应的目录,如果没有修改过安装目录,就是图里显示的默认安装位置,然后点击确定。

默认安装位置

验证配置是否成功。

打开命令窗口,然后输入命令行:mysql -u root -p

接着输入 MySQL 密码,回车,如果显示出了 MySQL 的版本信息即说明配置成功了。(此处的 MySQL 密码就是安装时设置的密码)

配置成功

到这里 MySQL 全部安装配置完成,可以正常使用 MySQL 了。

允许远程访问

通过连接 MySQL 的工具,用 root 用户进行远程连接,会提示如下连接失败的信息,说明未开放远程连接功能。

root 用户开放远程

打开命令窗口登录 MySQL 数据库,然后输入命令行:mysql -u root -p

接着输入 MySQL 密码,回车。(此处的 MySQL 密码就是安装时设置的密码)

进入 mysql 库

show databases;

use mysql;

查询 root 用户的访问域:select user,host from user where user = 'root';

对 root 用户的访问域进行更新并查看结果:update user set host = '%' where user = 'root';

执行权限刷新命令:FLUSH PRIVILEGES;

这一步必须做,否则不生效。

再次用 root 用户进行远程连接,出现如下报错:

这是因为 MySQL 8.0 默认使用 caching_sha2_password 的身份验证机制,原来是 mysql_native_password 的身份验证机制。

所以需要重新对 root 用户更改身份验证机制:ALTER USER 'root'@'%' IDENTIFIED WITH mysql_native_password BY 'root';

再次用 root 用户进行远程连接,出现 “Access denied for user 'root'@'MCHN53446' (using password: YES)” 的报错。

原因是上面对 root 用户修改了访问域,从 localhost 改成了 %,所以这里还需要重新对 root 用户设置密码,否则无法进行远程访问。

ALTER USER 'root'@'%' IDENTIFIED BY 'pc123456';

再次用 root 用户进行远程连接,成功。

新用户开放远程

创建新用户用于远程访问:create user 'zhangsan'@'%' identified by '123456';

给用户赋予操作数据库的权限(这里赋予的是所有权限):grant all on *.* to 'zhangsan'@'%';

使用 zhansan 用户进行远程连接,出现如下报错:

这是因为 MySQL 8.0 默认使用 caching_sha2_password 的身份验证机制,原来是 mysql_native_password 的身份验证机制。

所以需要对 zhangsan 用户更改身份验证机制:ALTER USER 'zhangsan'@'%' IDENTIFIED WITH mysql_native_password BY 'zhangsan';

之后就可以通过 "zhangsan" 用户,对数据库进行远程访问了。